Welcome to the Koken CMS community!

Here at KCS, you will find a friendly bunch of photographers who like to share their love for the Koken CMS. We hope that you will enjoy your time here and thrive in our community!

You asked for it: Donations!
You asked for it, and it's here: The possibility to "buy me a beer (or more)"!

Seriously: By giving a small paypal donation you will help with keeping this site afloat and also give me more incentive to develop OxyGen further... ;)

// Bjarne Varöystrand and the KCS Team
Koken Development

issues with libraries, sets and albums

Issues regarding Image/video importing, editing, and grouping.
Make sure you have read the Library tutorials here
Forum rules
As of late, we have been seeing cases where some of you have been posting multiple types of questions within a singular type of topic...

This makes searching here a nightmare for people whom are attempting to find out whether or not their question has already been asked, or possibly even answered. Therefore, I would like to implement some very basic rules, which I think everybody will be happy with, given that they will lead to better search results.

  1. All public communication is done in English
  2. ONE question per topic
  3. Make the title descriptive
  4. If it's regarding a theme: make sure you mention the theme name.
  5. Leave a URL to your site, since sometimes, custom "hacks" and CSS will be uniqe to your site.

I believe that these simple rules will not only make our lives easier, but also the lives of our visitors :D

I am of the opinion that ignoring these requests will make it harder for us all.
Plus, we won't be able to actually mark an issue/topic as solved, since it would be more difficult to determine what we're actually trying to solve! For example: Are we addressing the first, second or third question?
CChris
User
User
Posts: 7
Joined: Sat 20 Feb 2016, 20:36
Your name: Christoph

issues with libraries, sets and albums

Postby CChris » Sun 01 Jul 2018, 19:20

Hi there,
I'm using Koken for a while now, but since I moved my site to another server (was once hosted on a vhost from a friend of mine - and now I have my own vhost) - I have some issues with albums and libraries within my koken installation.

First, I've noticed, that the site could not load images within some albums.
The Admin-Site did only show the loading circle, and nothing else happened.
Also, the images won't be loaded, if I open the album directly within my page design.

I only see a blank page in the page layout.
Then, suddenly, after creating one library again and again, it worked... a few days later, I could not open this library again.
Image uploading at all is working fine - and also, the new uploaded images are getting displayed in the content section itself.

Another issue I have found is, that I can't delete librarys / albums I have created on the old webserver.

I have tried to use PHP 7.0.22 as "FPM Application" and also PHP 5.6.36 but it seems, that it wont work with both versions.
Maybe, it is related with some rights, or with another component on my server (with some other settings), since it seems only to affect new created albums, etc.pp.)

Any help would be much apreciated, since I don't get any response from the NetObject Koken Team :-(
CChris
User
User
Posts: 7
Joined: Sat 20 Feb 2016, 20:36
Your name: Christoph

Re: issues with libraries, sets and albums  Topic is solved

Postby CChris » Tue 03 Jul 2018, 20:19

Issue solved :)

first, I've tried the installation of php7-xml which I have found as a possible solution for a similar issue.
But this didn't help.

then, I found another similar topic within the Koken Support pages, where the Koken-Team mentioned a corrupted Database.
They have provided a SQL statement...

Code: Select all

UPDATE koken_albums a, (SELECT @i := 0) m
SET level = 1,
a.left_id = @i := @i + 1,
a.right_id = @i := @i + 1;


I think, I have seen this SQL somewhere here in the forum, too - but I was not able to find it immediately (maybe, because I just searched for "SELECT" instead of "UPDATE")

This select solved ALL my issues I've had with Libraries, Albums and Sets.

Just for your refference, if someone will have the same / or similar issues with his installation.
User avatar
Bjarne Varöystrand
Webbplatsadministratör
Webbplatsadministratör
Posts: 1063
Joined: Sun 29 Mar 2015, 21:02
Your name: Bjarne Varöystrand
Location: Lysekil, Sweden
Contact:

Re: issues with libraries, sets and albums

Postby Bjarne Varöystrand » Wed 04 Jul 2018, 21:45

Good to hear you solved it! :)

I believe that this might be the link you where looking for :ugeek:
Regards
Bjarne Varöystrand - Image || Reddit || Twitter|| Facebook

Image

  • Similar Topics
    Replies
    Views
    Last post

Return to “Library”



Who is online

Users browsing this forum: No registered users and 1 guest