Welcome to the Koken CMS community!

Here at KCS, you will find a friendly bunch of photographers who like to share their love for the Koken CMS. We hope that you will enjoy your time here and thrive in our community!

You asked for it: Donations!
You asked for it, and it's here: The possibility to "buy me a beer (or more)"!

Seriously: By giving a small paypal donation you will help with keeping this site afloat and also give me more incentive to develop OxyGen further... ;)

// Bjarne Varöystrand and the KCS Team
Koken Development

Configuring Regale 2 theme

Theme editing, customization and publishing.
Official documentation is here
Forum rules
As of late, we have been seeing cases where some of you have been posting multiple types of questions within a singular type of topic...

This makes searching here a nightmare for people whom are attempting to find out whether or not their question has already been asked, or possibly even answered. Therefore, I would like to implement some very basic rules, which I think everybody will be happy with, given that they will lead to better search results.

  1. All public communication is done in English
  2. ONE question per topic
  3. Make the title descriptive
  4. If it's regarding a theme: make sure you mention the theme name.
  5. Leave a URL to your site, since sometimes, custom "hacks" and CSS will be uniqe to your site.

I believe that these simple rules will not only make our lives easier, but also the lives of our visitors :D

I am of the opinion that ignoring these requests will make it harder for us all.
Plus, we won't be able to actually mark an issue/topic as solved, since it would be more difficult to determine what we're actually trying to solve! For example: Are we addressing the first, second or third question?
User avatar
andyj
Donator
Donator
Posts: 3
Joined: Sat 12 Jan 2019, 14:31
Your name: Andrew Johnson

Configuring Regale 2 theme

Postby andyj » Sun 20 Jan 2019, 15:16

Hi everyone,

This is my first post here. I installed Koken a few weeks ago and have been getting used to it: mostly I'm very impressed.

Until now I've been using the free themes, but yesterday I bought a copy of the Regale 2 theme and I'm having problems configuring it. When I go onto the Site tab I just get a "spinner" in the centre of the Draft and Live panels. I've tried leaving it for a while but nothing ever appears in the main part of the screen. Clicking the cog icon at the top-right does nothing either. I've successfully applied and published the theme, and the live site is definitely using it, and I just don't seem to be able to configure it.

I've tried clearing the Koken app's system cache, refreshing, shift-refreshing, re-starting the browser, logging out and back in to Koken. I'm using Firefox 64.0.2 (64-bit) on Windows 10 with 8GB memory. At the server-side I'm using Koken 0.22.24 (latest version, as far as I know).

Does anyone have any suggestions for things to try?

Thanks, Andy.
User avatar
andyj
Donator
Donator
Posts: 3
Joined: Sat 12 Jan 2019, 14:31
Your name: Andrew Johnson

Re: Configuring Regale 2 theme

Postby andyj » Tue 22 Jan 2019, 13:37

A quick follow-up:

I've tried a couple of different browsers (Edge and Chrome). No difference. I've also realised that I can configure the primary and footer links using the items in the sidebar, so the theme is responding some config changes.

But I'm still unable to access the config settings described at https://store.koken.me/themes/regale/guide/1.

I've contacted netobjects/koken support but not had a response back as yet. I'd be grateful for any suggestions.

Andy
User avatar
andyj
Donator
Donator
Posts: 3
Joined: Sat 12 Jan 2019, 14:31
Your name: Andrew Johnson

Re: Configuring Regale 2 theme

Postby andyj » Wed 30 Jan 2019, 14:59

Another update.

Looking in the firefox dev console I can see an error:

Code: Select all

Uncaught TypeError: Cannot read property 'contentWindow' of null
    at t.refresh (koken-core.js:16885)
    at Object.(/photos/admin/draft|live)/?((theme|page)/?)?(url:(.*)$)?
    at String.<anonymous> (koken-core.js:1060)
    at Function.each (jquery.min.js:2)
    at t.router (koken-core.js:1042)
    at koken-core.js:3142
    at e (jquery.bbq.js:890)
    at dispatch (jquery.min.js:3)
    at r.handle (jquery.min.js:3)


Luckily I'm a developer :) Inside the refresh() function are a couple of lines of javascript:

Code: Select all

            var iframe = document.getElementById('siteui-iframe');
            if (iframe.contentWindow.$K && !force) {
               iframe.contentWindow.$K.loadUrl(path);
            } else {
               $(iframe).attr('src', path);

The error occurs on the second line because iframe is null, because getElementById() is returning null, presumably because an element named "siteui-iframe'" doesn't exist in the document. From the way the code is written, this doesn't seem to be an expected occurrence, so I'm assuming this is a software error. Has anyone seen this kind of thing in Koken? Is there a channel for reporting such things to NetObjects?

Andy
User avatar
Bjarne Varöystrand
Webbplatsadministratör
Webbplatsadministratör
Posts: 1063
Joined: Sun 29 Mar 2015, 21:02
Your name: Bjarne Varöystrand
Location: Lysekil, Sweden
Contact:

Re: Configuring Regale 2 theme

Postby Bjarne Varöystrand » Wed 30 Jan 2019, 15:11

This sounds very strange, I just tried to replicate the problems locally with my Regale 2: without success!
Regards
Bjarne Varöystrand - Image || Reddit || Twitter|| Facebook

Image

  • Similar Topics
    Replies
    Views
    Last post

Return to “Site Publishing”



Who is online

Users browsing this forum: No registered users and 2 guests